centos6默认安装的是php5.3
现在要升级到php5.6+

卸载旧版本php

1
yum remove php php-common

增加yum源

1
2
rpm -Uvh https://dl.fedoraproject.org/pub/epel/epel-release-latest-6.noarch.rpm
rpm -Uvh https://mirror.webtatic.com/yum/el6/latest.rpm

重新安装

1
yum install php56w php56w-fpm php56w-gd php56w-mbstring php56w-mysql php56w-pdo php56w-xml

参考文档

  1. http://www.cnblogs.com/savokiss/p/6259816.html